PicoSvoxOOo

1ER FÉVRIER 2019 — PAR MANQUE DE TEMPS, JE NE SUIS PLUS EN MESURE D’ASSURER LA MAINTENANCE DE PICOSVOXOOO. LA VERSION QUI SE TROUVE ICI EST OBSOLÈTE ET NE FONCTIONNE PROBABLEMENT PLUS.

PicoSvoxOOo est une extension développée par dessus la synthèse vocale Pico. Cette extension permet de faire lire un texte à haute voix depuis Writer, Draw ou Impress. Elle fonctionne sous Linux et Windows pour LibreOffice, Apache OpenOffice, OOo4Kids et OOoLight.

Il est possible de lire un texte mot par mot, phrase par phrase ou paragraphe par paragraphe, et de passer au passage suivant par simple clic.

La barre d’outils se présente de la façon suivante :

barre_picosvoxoooLe triangle vert déclenche la lecture du texte sélectionné.

Depuis la version 1.0 (voir TÉLÉCHARGEMENTS ci-dessous), des raccourcis clavier ont été ajoutés :

  • Alt+w = lecture du mot courant
  • Alt+k = lecture de la phrase courante
  • Alt+p = lecture du paragraphe courant
  • Alt+s = Arrêt de la lecture en cours
  • Alt+ -> = lecture du passage (mot, phrase ou paragraphe) suivant
  • Alt+ <- = lecture du passage (mot, phrase ou paragraphe) précédent
  • Alt+r = répète le dernier morceau de texte lu

Une option permet également la lecture en cours de frappe : dès que la frappe d’un mot est terminée, le mot est lu.

TÉLÉCHARGEMENTS

Vous utilisez OpenOffice, Apache OpenOffice version 2.3 ou 3, LibreOffice, OOoLight ou OOo4Kids :
download_arrow

Vous utilisez Apache OpenOffice version 4.1 :download_arrow

ATTENTION : sous Windows, l’extension fonctionne avec Apache OpenOffice 4.1 et plus uniquement, pas avec Apache OpenOffice 4.

Sous Linux, il faut installer la synthèse Pico pour que l’extension fonctionne.

4000

4000 téléchargements depuis l’installation de LireCouleur sur le site des extensions pour OpenOffice / LibreOffice et autres OOo ! C’est plutôt intéressant.

Si certains d’entre vous avaient la gentillesse de me laisser un message pour dire comment LireColeur est utilisé, je serais ravie.

Correctif 3.1.1

Je pensais avoir récolu les problèmes d’utilisation de LireCouleur avec LibreOffice 4 mais il en restait un de taille ! Ce problème empêchait l’affichage des phonèmes en couleur. Il est maintenant résolu avec le correctif 3.1.1 mis en ligne ce soir.

Pour télécharger le correctif : http://extensions.openoffice.org/fr/project/LireCouleur

J’ai profité de cette correction pour ajouter une entrée dans le menu LireCouleur. Cette entrée permet d’ouvrir un document LireCouleur (police élargie et interligne agrandi) directement.

Nouveau menu 3.1.1
Nouveau menu 3.1.1

Publication de la version 3.1

Finalement, il n’y a pas eu de version 3.0.4 finale publiée.

La dernière version porte le numéro 3.1. Elle est téléchargeable sur le site des extensions pour OpenOffice : http://extensions.openoffice.org/fr/project/LireCouleur

Une nouvelle fonction est disponible et permet de mettre en évidence uniquement les sons complexes d’un texte. Pour cela, il est toujours nécessaire de préciser les sons à faire apparaître via la boite de configuration.

Les espaces allongés ont été supprimés. Ils introduisaient des perturbations lorsqu’on voulait ensuite modifier le texte. Pour espacer les mots d’un texte, les espaces sont dupliqués et le nombre d’espaces à utiliser est configurable.

Il est également possible de modifier la couleur et la typographie des lignes qui assurent l’alternance des couleurs (voir fonction Lignes de couleurs). Les lignes ont les styles altern_ligne_1, altern_ligne_2, etc.

Bien entendu, si vous rencontrez des difficultés ou si vous avez des questions, n’hésitez pas à me contacter.

 

Autoriser l’utilisation des macros avec OOo

Le modèle LireCouleur intègre l’ensemble des outils de formatage de texte sans avoir besoin d’installer l’extension. Pour pouvoir utiliser ce modèle, il faut autoriser l’utilisation des macros.

Pour cela, il faut tout d’abord lancer OOo, puis cliquer sur « Options » dans le menu Outils.

Dans les options de Sécurité, cliquer sur Sécurité des macros.

Configuration des options de sécuritéSélectionner le niveau de sécurité moyen et valider. Il faut ensuite fermer le document courant pour que le changement d’option soit pris en compte.

Niveau de sécurité moyenLorsqu’un document contenant des macros est sélectionné, une confirmation est demandée :

Autoriser l'utilisation des macros

Cliquer sur Activer les macros pour accepter leur utilisation.